« 2.1chとか5.1chとか | トップページ | 今日のクワガタ »

2009年11月13日 (金)

libnutとlibgsmをMacに

ネイティブなNUTのmuxer/demuxerです。動画のmuxに必要なモノ、、と覚えておきましょう。動画と音声とをくっつけたり分離したりするヤツですかね?(実はあんまりわかってません。)
svn co svn://svn.mplayerhq.hu/nut/src/trunk libnut
で、最新をまずはgetだ。

あとはmake && make install でOKです。

これは簡単に入りますね。次はlibgsmを入れましょう。
http://user.cs.tu-berlin.de/~jutta/toast.html からソース持ってきます。
これもconfigure入ってませんので修正。makeは通りますので手動で入れてもかまいませんが。

74行目
INSTALL_ROOT =/usr/local

83行目
GSM_INSTALL_INC = $(GSM_INSTALL_ROOT)/include

に変更したらmake install もいけます。

さーて、ffmpegも--enable-libnut --enable-libgsmしておこうかな。

|

« 2.1chとか5.1chとか | トップページ | 今日のクワガタ »

コメント

コメントを書く



(ウェブ上には掲載しません)




トラックバック


この記事へのトラックバック一覧です: libnutとlibgsmをMacに:

« 2.1chとか5.1chとか | トップページ | 今日のクワガタ »