« カブト続々! | トップページ | ミヤマが蛹化 »

2011年7月26日 (火)

LionでffmpegのBuildが?

OSX、Lionですが。

ffmpegのBuildがうまくいきません。 具体的には--enable-gplのオプションをつけると下のようなエラーが出ます。

Ffmpegerr

gplライセンスのlibをつけることができないのでは・・・ キツいです。libx264とかlibxvidとかが使えないんですよ。libfaac/faadは外されたようですが、まぁそれはいいんですがね。

うーむ。困った困った。

追記:avcodecのほうではちょい前から報告された問題だったようですね。すでに回避策もあるそうですよ。

./configureのオプションに--cc=clang を付けると回避できるそうです。

Ffmpegok

というわけで、無事にffmpegの最新がLion上でBuildできましたよ〜〜ン。 ふふふ。

|

« カブト続々! | トップページ | ミヤマが蛹化 »

コメント

コメントを書く



(ウェブ上には掲載しません)




トラックバック


この記事へのトラックバック一覧です: LionでffmpegのBuildが?:

« カブト続々! | トップページ | ミヤマが蛹化 »